ActiveRecord 3.1.0 – 3.1.2 and Postgres

It is a new year and we’re excited about a number of new features we’ll be announcing over the course of the next few weeks.  In the meantime, those of you using ActiveRecord 3.1.0 through 3.1.2 together with the Postgres database adapter may want to consider updating to ActiveRecord 3.1.3.  We’ve seen a number of folks get bitten by the statement cache DEALLOCATE query that early versions of ActiveRecord 3.1 issued during a reconnect! method call.  It is a pretty nasty surprise to get an unexpected exception when the database connection drops and ActiveRecord attempts to reconnect.  You can read more about the bug and the patch in 3.1.3 here.

Post a Comment